Installare Wine su Ubuntu 7.10 AMD64

Realizzo questa breve guida con l’intenzione di creare una piccola raccolta di tuttorial di installazioni su distribuzioni ubuntu amd64, visto la difficoltà per utenti che utilizzano queste distribuzioni di trovare informazioni a riguardo (ancora maggiore se cercano qualcosa scritto in italiano).

Vi rimando quindi a quest’altra guida su come installare awn su ubuntu amd64.

Mi rifaccio alla guida ufficiale sul sito spagnolo di ubuntu.

Aprite un terminale e date questo comando (1 riga)

wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add –

poi, sempre da terminale scrivete (1 riga)

sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/gutsy.list -O /etc/apt/sources.list.d/winehq.list

Infine installate wine dando questi 2 comandi

sudo apt-get update
sudo apt-get install wine

Se tutto è andato a buon fine potrete trovare Wine nel menù principale sotto Applicazioni

Per installare i fonts di Windows in modo da visualizzare correttamente i programmi emulati, e avviarli semplicemente con un doppio click scrivete da terminale:

sudo apt-get install binfmt-support msttcorefonts

Per avviare l’emulazione del programma basta fare doppio click sul programma interessato, oppure cliccare su questo col tasto destro e selezionare Apri con applicazione…>Wine windows Emulator.

Nel caso in cui avete bisogno di configurare Wine per l’uso di librerie particolari potete farlo cliccando su Applicazioni>Wine>Configure Wine, oppure scrivendo da terminale winecfg.

Ringraziementi per le modifiche apportate: Lusis.

Ciao😉

Tag: , ,

21 Risposte to “Installare Wine su Ubuntu 7.10 AMD64”

  1. Manu T Says:

    Scusa la mia ignoranza, ma non ho mai installato Wine finora. Questi comandi funzionano anche per un normale Intel 32 bit?

  2. Louis Mendoza Says:

    io vorrei sapere una cosa…ma devo essere collegato ad internet, per fare questa cosa?
    nel caso, c’è un modo per poter scaricare i files che servono da windows e portarli su ubuntu, dato che ho tutti e due i sistemi operativi?
    grazie!

  3. cliccaqui Says:

    @Manu T
    Ciao…
    penso che vada bene solo per gli amd64, anche perchè non ho avuto modo di provare su una distribuzione a x86…
    Comunque se hai una ditro a 32 bit ti basta andare in Applicazioni>Aggiungi/Rimuovi e scrivere wine nella casella di ricerca, spuntare la relativa casella e premere il tasto applica modifiche…

    Ciao😉

  4. cliccaqui Says:

    @Louis Mendoza

    Ciao, si è neccessario essere connessi ad internet…
    comunque si, mi sembra che si possano scaricare i pacchetti a parte e poi installarli… mi informo meglio poi ti faccio sapere il metodo preciso…
    ciao😉

  5. lusis Says:

    @Manu T
    Sì🙂

    @Louis Mendoza

    Si è possibile, devi scaricarti
    http://wine.budgetdedicated.com/archive/ubuntu/gutsy/wine_0.9.54~winehq0~ubuntu~7.10-1_i386.deb (per i 32 bit)
    oppure
    http://wine.budgetdedicated.com/archive/ubuntu/gutsy/wine_0.9.54~winehq0~ubuntu~7.10-1_amd64.deb
    per gli intel/amd a 64 bit

    potresti dovere scaricare anche binfmt-support da qui:
    http://archive.ubuntu.com/ubuntu/pool/universe/b/binfmt-support/binfmt-support_1.2.10_all.deb
    (per entrambe le piattaforme)

    poi una volta in ubuntu fai doppio click sul .deb e lo installi.

  6. Louis Mendoza Says:

    ok, grazie!🙂

  7. cliccaqui Says:

    @lusis

    Grazie😀
    ciao😉

  8. Louis Mendoza Says:

    grazie, davvero, Lusis!🙂

  9. Manu T Says:

    più chiaro di così si muore! Grazie Mille =)

  10. Ilio Says:

    Non riesco ad installare ne a risolvere le dipendenze , cosa ne pensate ?

    ilio@pc1:~$ sudo apt-get install wine
    Lettura della lista dei pacchetti in corso… Fatto
    Generazione dell’albero delle dipendenze in corso
    Reading state information… Fatto
    Alcuni pacchetti non possono essere installati. Questo può voler
    dire che è stata richiesta una situazione impossibile oppure, se
    si sta usando la distribuzione “unstable”, che alcuni pacchetti
    richiesti non sono ancora stati creati o rimossi da incoming.

    Poiché è stata richiesta solo una singola operazione è molto facile che
    il pacchetto semplicemente non sia installabile, si consiglia
    di inviare un “bug report” per tale pacchetto.
    Le seguenti informazioni possono aiutare a risolvere la situazione:

    I seguenti pacchetti hanno dipendenze non soddisfatte:
    wine: Dipende: ia32-libs (>= 1.6) ma non sta per essere installato
    Dipende: lib32asound2 (> 1.0.14) ma non è installabile
    Dipende: libc6-i386 (>= 2.6-1) ma non è installabile
    E: Pacchetto non integro
    ilio@pc1:~$ sudo gedit /etc/apt/sources.list

  11. cliccaqui Says:

    @Ilio
    Ciao, che distribuzione usi? è 32 o 64bit? sicuro di aver seguito tutti i passaggi?
    Ciao🙂

  12. Ilio Says:

    64 bit , certo ho scaricato manualmente tutti i pacchetti uno per uno quelli richiesti per soddisfare le dipendenze ma nulla non c’è modo ho provato di tutto . In poche parole viene rilevato un problema di versione delle lib . Ho provato perfino ad installare la 32 bit ma mi da giustamente errore di architettura. Ma non riesco ad uscirne veramente e non la vedo bene!

  13. cliccaqui Says:

    @Ilio
    E’ strano, tu stai usando la 7.10 o la 8.04 beta?
    se usi la 7.10 quello che posso consigliarti è di verificare se hai abilitato tutte le sorgenti sofware a cui attinge l’apt-get (per farlo Sistema>Amministrazione>Sorgenti software e mettere tutti i segni di spunta, a parte “Codice sorgente” a meno che non ti interessi)
    e poi riprovare a fare
    sudo apt-get update
    sudo apt.get install wine

    se sei sulla 8.04 penso che questa installazione non vada bene perchè è specifica per gutsy…
    facci sapere…
    ciao:)

  14. Ilio Says:

    Niente da fare ecco il risultato come solito :

    I seguenti pacchetti hanno dipendenze non soddisfatte:
    wine: Dipende: ia32-libs (>= 1.6) ma non sta per essere installato
    Dipende: lib32asound2 (> 1.0.14) ma non è installabile
    E: Pacchetto non integro
    ilio@pc1:~$

    la versione è la 7.10 gutsy per 64 bit su athlon 3500 , ormai so esausto è da stamattina che ci provo , se risolvo prima di che finisco di scaricare la suse bene altrimenti monto la suse e basta, Mi piaceva ubuntu ma per me wine è irrinunciabile . Aiutatemi voi a risolvere ricambierò!

  15. cliccaqui Says:

    @Ilio
    ma avevi provato già ad installare wine da altre guide?
    comunque sia, prova a disinstallare quello che hai messo dando
    sudo apt-get remove wine
    e prova a ripetere la procedura dall’inizio.
    ciao:)

  16. Ilio Says:

    Scusa ehh ma se non sono riuscito ad installare nessun pacchetto è ovvio che remove non toglie nulla . Niente ho provato a seguire la guida ufficiale di wine, ho letto il wiki non ufficiale di ubuntu gutsy, il problema è che quando vado ad installare mi dice che ia32-libs non può esere installato (dipendenze) che non riesco a risolvere nemmeno scaricando manualmente i pacchetti , infatti quando do install il sistema risponde dicendo che la versione in uso e piu recente di quella da installare e non procede . inoltre se procedo da add-remove e cerco di spuntare wine non ottengo la selezione e dunque nulla non so veramente non so , vorrei capire se è successo solo a me ma ho forti dubbi comincio a pensare che è un problema di wine di compatibilità 32-64 bit .

  17. cliccaqui Says:

    @Ilio
    *l’apt-get remove era per rimuovere eventualmente installazioni parziali di wine effettute con altre guide (come ti avevo chiesto nella prima riga del commento)
    *non ti seleziona niente nell’add/remove perchè wine non è supportato uffucialmente nella versione AMD64 di ubuntu (come è scritto nella parte bassa della descrizione di wine nell’add/remove)
    *io ho un AMD64 con la 7.10 amd64 e questo procedimento ha sempre funzionato
    il problema sta nel tuo os, probabilmente durante l’installazione qualche file non è stato copiato correttamente, quindi ti conviene fare una reinstallazione per risolvere il problema.

  18. Ilio Says:

    Ok ci riprovo a installare il tutto, mi rincresce riconfiguarare nvidia e serverx perchè al riavvio mi va out range la frequenza del monitor e sevo settarlo manualmente, configurare rete, dns, ecc Grazie vi farò sapere …

  19. Ilio Says:

    Risolto , bene il bug è il seguente :
    https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-via/+bug/137735
    e va risolto così, editare xorg.cof accodando quanto segue:
    Section “Module”
    Disable “dri”
    Disable “glx”
    EndSection

    che disabilita il 3d .

    Inoltre da vedere : http://www.viaarena.com/default.aspx?PageID=420&OSID=25&CatID=2580&SubCatID=109

    Una domanda , qualcuno ha installato fireworksMX o 4 su Wine ? Ho un problema di NOT ENOUGH MEMORY … capitato a qualcuno !?

  20. Luca Says:

    una guida perfetta! Grazie!!

  21. cliccaqui Says:

    @Luca
    Di nulla🙂
    Grazie a te🙂
    ciao😀

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...


%d blogger cliccano Mi Piace per questo: